Ubuntu安装zabbix出错

jike_future750 企业大型监控系统 Zabbix... 最后由 jike_future750 于2017年03月02日回复

  • 2 回答
  • 2k 浏览

root@ubuntu:/# apt-get install zabbix-server-mysql zabbix-frontend-php

正在读取软件包列表... 完成

正在分析软件包的依赖关系树       

正在读取状态信息... 完成       

有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是

因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件

包尚未被创建或是它们已被从新到(Incoming)目录移出。

下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:

 zabbix-server-mysql : 依赖: libmysqlclient18 (>= 5.5.24+dfsg-1) 但无法安装它

                       推荐: virtual-mysql-server

                       推荐: snmpd 但是它将不会被安装

E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系

  • 极客学院_吕布 2017年03月02日 回答 #1楼
  • 解决办法:

    打开更新设置,在“更新”选项卡中选则:重要安全更新 和 推荐更新

    并在“其他软件”选项卡中,去掉有问题等源

    最后在命令行里输入

    sudo apt-get update

    更新一下即可

  • 0 评论
  • jike_future750 2017年03月02日 回答 #2楼
  • #1楼  @极客学院_吕布 

    验证页面提示

    PHP bcmath extension missing (PHP configuration parameter --enable-bcmath).PHP mbstring extension missing (PHP configuration parameter --enable-mbstring).PHP xmlwriter extension missing.PHP xmlreader extension missing.  应该怎么修改?
  • 0 评论