用luke来读创建的文件时显示 read past eof

kylinthinker Lucene 常用功能介绍 最后由 小鸡慢慢 于2015年06月30日回复

  • 2 回答
  • 5.1k 浏览

换回了lucene4.3后就可以了,但是用luke来读创建的文件时显示 read past eof

  • 极客学院_ASMITA 2015年06月30日 回答 #1楼
  • luke是分版本的,你去下个对应版本就好了,不同版本读取的时候会出问题

    一般报这个错是因为已经读取完文件了,但是luke版本不同,可能还在继续往后面读数据,

    结果就报这个错误了

  • 0 评论
  • 小鸡慢慢 2015年06月30日 回答 #2楼
  • luke是一个第三方小工具,主要用于开发过程中检验Lucene文件的。Lucene的每个版本都会有很大的改动,所以还请使用对应的版本。

  • 0 评论